Problema con sivp en Debian

noviembre 7, 2009 at 6:10 pm (yo y debian) (, , , , , )

Hola, acá escribiendo de nuevo sobre un problema que tenía (tenía, porque ya está solucionado) con un paquete del programa scilab. Voy a escribir la solución en parte porque colabora con la comunidad linux y también porque luego se me olvidará como solucionar este tipo de problemas.

El problema era el siguiente, había instalado scilab para hacer una tarea que nos dieron en la universidad, pero el paquete sivp quedó mal instalado y cuando quería volver a instalarlo, o simplemente eliminarlo, me aparecía el siguiente mensaje:

dpkg: error al procesar sivp (–remove):
el subproceso installed pre-removal script devolvió el código de salida de error 1
dpkg: error al reorganizar:
el subproceso installed post-installation script devolvió el código de salida de error 1
Se encontraron errores al procesar:
sivp

Así que buscando por Internet alguna solución, me encontré con una página donde ponían un consejo, dudo que fuese el más adecuado, pero el asunto es que solucionó el problema y pude desinstalar el paquete problemático.
Lo que hay que hacer es sencillo, vamos al siguiente directorio:
cd /var/lib/dpkg/info

y luego eliminamos los que tengan que ver con sivp:

rm sivp.*

Luego hacemos un
dpkg –remove sivp

y solucionado el problema.

Como dije, dudo que sea la opción que se deba hacer para eliminar el problema, sin embargo funciona, los dejo a su criterio, pongo a continuación la fuente de donde obtuve la información (en inglés, por eso me animé a ponerlo en español), clic aquí.

Saludos

Jqro

Anuncios

Permalink Dejar un comentario